Raspberry Pi, Volumio, Hifiberry DAC und Equalizer

Nach PI 2 kommt PI 3 und es war wieder soweit: ein funktionierendes System komplett erneuern. Komplett, da ich die Musik zukünftig auf der SD Karte speichern wollte und deshalb auf 128 GByte erweiterte. Klonen der alten SD Karte hat zwar einwandfrei funktioniert – jedoch auch mit der ungewollten Übernahme der alten Partionen(größen).

Es gibt mittlerweile unzählige Ansätze die o. g. Konstellation zum Laufen zu bringen (oder auch nicht). Hier beschreibe ich (für mich) die Vorgehensweise, wie es letztendlich bei mir funktioniert hat. Die Steuerung erfolgt über die volumio-app. Falls es jemandem hilft: umso besser!

Also von vorn.

[Hardware]

  1. Raspberry PI3 zusammenbauen und das Hifiberry DAC plus Modul aufstecken
  2. Im ersten Schritt den PI an ein Netzwerkkabel stöpseln

[SD-Karte]

  1. Auf der volumio-Seite die aktuelle Version herunterladen.
  2. Zip entpacken
  3. Etcher installieren (Windows) und Image auf die SD-Karte schreiben
  4. Karte einstecken und den PI starten

[Konfig]

Im PC-Browser über volumio.local den PI aufrufen und durch das Startmenü navigieren. Hier ist eigentlich nur die WLAN-Verbindung zu benennen, der Rest bleibt unverändert.

Im nächsten Schritt ein paar Musikstücke zum testen übertragen. Volumio bietet bei Verwendung der internen SD-Karte im (Windwos-)Netzwerk den Speicherort „internal storage“ an, der den restlichen Speicherplatz der Karte verwendet und somit für unseren Einsatz geeignet ist. Die abgelegte Musik wird problemlos über > MEINE MUSIK angezeigt und kann abgespielt werden. Die Einstellungen unter > WIEDERGABE sind unter Output „snd_rpi_hiberry_dacplus“, I2S DAC ist aktiviert (HifiBerry DAC plus ist ausgewählt) und Lautstärke „Hardware“ mit den entsprechend gewünschten Voreinstellungen.

Musik läuft, Lautstärke lässt sich über die Handy app regulieren.

Jetzt wollen wir aber den Klang noch etwas feiner abstimmen und hierfür die Equalizer Erweiterung nutzen. Also zurück zur volumio Oberfläche. Zunächst die laufende Musik stoppen(pausieren). Unter > PLUGINS > SUCHE PLUGIN > AUDIO INTERFACE > VOLUMIO SIMPLE EQUALIZER x.x.x auswählen und installieren. Unter „Einstellungen“ kann das Klangbild grundsätzlich justiert werden. Doch dazu später mehr.

[groll] Und jetzt geht der Ärger los: Nach der Aktivierung des plugins ist keine Musik mehr zu hören.

Neustart.

Unter > WIEDERGABE ist jetzt als Output „HifiBerry DAC Plus through equalizer plugin“. Das passt. I2S DAC ist nicht mehr aktiv (aber läuft im Hintergrund weiter). Bei > LAUTSTÄRKEEINSTELLUNG ist > ART DES MISCHERS „Keine“ zu sehen. Trotzdem keine Musik.

Neustart. Keine Musik.

Bei > LAUTSTÄRKEEINSTELLUNG > ART DES MISCHERS „Keine“ noch einmal unverändert speichern.

Neustart.

Jetzt kommt plötzlich wieder Musik. Unter „Einstellungen“ des Equalizer plugins werden Änderungen im Klangbild auch wirksam („apply“ klicken). Jedoch kann die Lautstärke jetzt nicht mehr über die volumio app geregelt werden!

Auf dieser Basis kann man jetzt tagelang rumfummeln. Bei mir ging immer mal wieder das eine, dann das andere – aber nie alles zusammen, so wie man es gerne hätte. [/groll]

Im neuen Browser-TAB ssh einrichten. Hierzu volumio.local/DEV aufrufen und im Dialogfenster unter „SSH“ auf ENABLE klicken. Es kommt keine sichtbare Reaktion, aber das hat trotzdem funktioniert.

Ein Terminalfenster öffnen und mit

# ssh volumio@192.168.178.x

die Verbindung herstellen. PW ist „volumio“ Die genaue Adresse ist z. B. über den Eintrag „Netzwerk“ im Router zu sehen.

Jetzt kann über diese Anleitung alsa installiert werden. Ich habe mich exakt an die Anleitung gehalten, lediglich die 0 durch 1 ersetzt, da meine Karte auf Position 1 angezeigt wurde. Mit dem aktuellen volumio-Build waren bereits einige alsa Pakete und Konfigurationen vorinstalliert, so dass es hie und da nur noch kleinere Anpassungen gemäß der Anleitung bedurfte. Es ist auch nicht notwendig, über den grafischen alsa Equalizer Einstellungen vorzunehmen – wir wollen ja das eigene volumio plugin verwenden.

Neustart.

Jetzt hat tatsächlich wieder alles funktioniert:

  • Musik läuft
  • simple equalizer plugin ist aktiv und Änderungen werden übernommen
  • Lautstärkeregelung ist unter „Hardware“ wieder vorhanden und kann über die volumio app gesteuert werden.

Ggf. muss das plugin noch einmal de- und wieder aktiviert werden, bzw. ein paar mal neu gestartet werden. Die Grundinstallation passt so aber.

Fazit: volumio-OS und simple equalizer plugin allein reichen nicht aus: es muss noch das alsa Paket installiert und wie o. g. konfiguriert werden.

Kommentar

Die E-Mail Adresse wird nicht veröffentlicht. Required fields are marked *